Ubuntu 9.10 “Karmic” – status og bugrapport

Etter forrige ukes eksemplariske installasjon av siste Ubuntu-versjon har jeg nå begynt å oppdage de første bugene. Det vil alltid være noe å sette fingeren på etter en oppgradering, og så langt har jeg hatt langt mindre etterinstallasjonstrøbbel med “Karmic Koala” enn jeg periodevis hadde med forrige versjon. Her er de mest irriterende feilene så langt, med den minst alvorlige først:

  1. Ved avspilling av film blir fargene negative. Det viser seg at VLC og Movie Player ved installasjon kan få satt en “Hue”-verdi som gir denne effekten. Fiks: Nullstille “Hue”. Det gjør man i f.eks. Movie Player ved å gå til Edit/Preferences/Display og trykke “Reset to defaults”.
  2. Evolution kræsjer ved åpning av vedlegg. Denne rapporterte bugen viser seg når man åpner en fil ved å dobbeltklikke, eller prøver å lagre den. Siden jeg mottar drøssevis med vedlegg hver dag med Evolution, er dette en seriøst irriterende sak. Workaround: Åpne vedleggene i Gmail. Oppdatering: Denne bugen er ikke fullt så påtrengende etter siste systemoppdatering, men forekommer sporadisk fremdeles.
  3. Empathy får grafikksystemet til å låse seg. Empathy fases nå inn som standard-chatteklienten i Ubuntu. Jeg hadde imidlertid ikke kjørt den i mange minutter før det grafiske grensesnittet (Gnome) sto bom fast. Jeg kom meg ut av problemet ved å taste CTRL-ALT-F4, logge meg på uten grafikk og taste killall empathy. Workaround: Kjør Pidgin istedet. Ser penere ut, og har flere plugins uansett. :-)
  4. Dvalefunksjonen er ustabil. Denne buggen er rett og slett trist, da forrige Ubuntu-versjon så ut til å ha knekket den gamle Linux-nøtta en gang for alle. For øyeblikket er jeg i samme situasjon som for to versjoner siden, da jeg aldri kunne vite om grafikksystemet eller wifi våknet til live etter dvale. Workaround: Har ikke funnet noen så langt.
  5. “Mount not found” ved oppstart. Denne utrivelige feilmeldingen dukket opp for to dager siden, og siden har jeg sett den et par ganger. Nå fikk den nettopp maskinen til å stoppe under oppstart og sende meg til et “recovery terminal window”. Jeg fulgte instruksjonene i terminalvinduet om å taste CTRL-D, hvorpå oppstarten fortsatte med at disksystemet ble scannet med fsck. Workaround: Har ikke funnet noen så langt. Oppdatering: Det er mulig at dette skyldes at en Sony Reader-leseplate er blitt lagt inn i fstab ved en feil.
  6. Spotify fungerer ikke: Ved oppstart av Spotify blir lyden skurrete og uklar. Fiks: Denne fra kommentarfeltet løste problemene for meg.

Hvordan er med mine med-pingvinister? Noen flere som har trøbbel, eventuelt forslag til løsninger? :-)

Share/Bookmark

34 kommentarer

  1. Fungerer stort sett bra, men har hatt problemer med ekstremt treg dns-kommunikasjon. Dette har jeg klart å løse ved å følge denne anvisningen: http://jon.thysell.us/2009/09/05/setup-a-persistent-local-dns-cache-on-ubuntu-jaunty-with-pdnsd-and-opendns/, problemet mitt er at det resettes etter hver omstart. Det samme gjelder andre løsninger jeg har forsøkt.

    I tillegg er Gwibber (dessverre) en stor skuffelse.

  2. Audun Wangen says:

    Har også hatt en del problemer etter oppgradering, men så ut som alt løste seg etter en reinstallasjon. Har egentlig hatt småproblemer med oppgradering hver gang, så jeg kommer til å gjøre det til en vane å kjøre installasjon fra bunnen av.

    Har du prøvd å slette/endre navn på innstillingsmappene til programmene som oppfører seg rart (e.g. ~/.mplayer, ~/.vlc etc.)? Det hender det må til etter en oppgradering.

  3. Eirik says:

    @Audun: Jeg tror du har fullstendig rett. Med tanke på hvor mange programpakker som byttes ut, med tilhørende instillinger som skal tilpasses, skulle det bare mangle at det krøller seg til for noen av dem. Skal utvilsomt sjekke ut tipset ditt mht til Evolution, som er mest irriterende akkurat nå…

  4. Jeg har nok sett snurten av den Empathy-buggen jeg, også. Har hatt “ett frys”, og da kjørte jeg Empathy. Tror jeg følger pidgin-rådet ditt, jeg kan ikke se hva som er bedre i Empathy enn det var i Pidgin. Og jeg takker for tipset!

    Andre problemer? Vel, ikke i særlig grad. Jeg er stort sett overveldet over hvor mye greiere maskinen ble å bruke etter oppgraderingen, jeg. Det meste går raskere, grafikksystemet er mer responsivt og den rimelig tunge Compiz-bruken jeg har lagt meg til, glir smooth som i en softdrinkreklame.

    Dvalefunksjonen bruker jeg stort sett ikke, men jeg skal gi den noen tester ved anledning. Det eneste lille irritasjonsmomentet jeg har nå, er at Bluetooth plutselig er enablet ved boot. Jeg kan ikke se noen måte å disable det på. Det var ikke slik i 8.10, eller i Redmond-OSet jeg også booter på samme maskina (når jeg skal kjøre Trackmania, that is).

    Men ellers er jeg lykkelig buggfri fremdeles.

  5. Eirik says:

    @Lasse: Jeg planlegger faktisk et lite eksperiment som vil klargjøre om problemene jeg har kan skyldes rusk fra gamle versjoner av ulike programmer, mer enn selve Karmic. Mer om det senere… :-)

  6. Audun Wangen says:

    @Lasse: Når det gjelder bluetooth, så finnes det flere tips på Ubuntu forumet for hvordan det kan slås av ved oppstart. Det er for eldre versjoner av Ubuntu, men jeg regner med at ett av dem funker.

    Det skal i utgangspunktet være slik at den går opp i samme status som den var i når du slo av maskinen, men det ser ut som det er gjort endringer i kjernen/kjernemoduler som gjør at det ikke alltid funker.

    @Eirik: Jeg bruker forresten hvilefunksjonen flittig på min bærbare, og det fungerer i alle fall smertefritt. Dvale har jeg ikke testet i Karmic, men det fungerte utmerket i Jaunty.

    Hm. Kanskje jeg skulle bidra litt på LaptopTesting på Ubuntu Wiki igjen.

  7. En ting til jeg hadde problemer med var Spotify under Wine. Lyden ble så forvrengt at det var umulig å høre på. (Problemet var kun i Spotify.)

    Problemet er delvist løst ved å endre Wine-versjonen:
    sudo apt-get remove wine
    sudo apt-get install wine1.2

    Grunnen til at jeg skriver delvis er at hvis jeg kjører andre programmer som genererer lyd (f.eks Pidgin), så hakker det fremdeles i Spotify. Men ikke ellers. :)

  8. Eirik says:

    @Erol: Takk for tipset! Jeg prøvde nemlig å høre på Spotify idag, og det lød for j*vlig. Får prøve å bytte Wine-versjon, jeg også.

    Oppdatering:
    Jeg oppgraderte pekeren til Medibuntu (se oppskriften her), kjørte en oppdatering og vips var problemene med Spotify borte uten at jeg behøvde å gjøre noe med Wine.

  9. […] This post was mentioned on Twitter by astronewth, Fredrik Sjursæther. Fredrik Sjursæther said: RT @astronewth: Hvor lenge var Adam i paradis? Siste Ubuntu-versjon har sine bugs, dessverre: http://tinyurl.com/yeuqpd7 […]

  10. Oppgraderte til Kubuntu Karmic i går, og multiscreen-støtten har blitt om mulig enda værre.

    setup: laptop med ati radeon kort (ja, jeg har IKKE valgt det selv) og 2 eksterne skjermer (1 dvi, 1 vga)

    med 9.04 måtte jeg med xrandr:

    enable DVI, disable laptop-skjerm. enable vga, sette vga ved siden av dvi

    med 9.10 må jeg:

    boote med dvi plugget ut.
    enable VGA.
    disable laptop-skjerm
    plugge inn dvi.
    enable dvi
    disable vga
    enmale vga og sette ved siden av dvi…

    og multiscreen-valget i control panel: sier jeg ikke har et multiskjerm-setup.

    Spotify har alltid fungert glimrende her, og ellers har jeg ikke opplevd noen særheter.. Jo, firefox nektet å starte, måtte startes i safe-mode først..

    Men: lengter jeg tilbake til windows: nope!

  11. Eirik says:

    @Atle: OK, du er en sann entusiast! Tror jeg hadde vært klar for å svitsje til Windows 7 med slike problemer i hverdagen… ;-)

  12. Hehe, er jo bare å ikke restarte maskina så funker det jo etter å ha gjort det en gang! ;)

    Ellers så venter jeg spent på noen fikser til dette problemet, regner med at det har ganske høy prioritet!

    Win7 høres så ukjent og skummelt ut for meg, blir så mye nytt å lære seg og sånn. Da holder jeg meg heller til et operativsystem jeg kjenner!

  13. Jon Harald Søby says:

    Jeg har problemer med lyden; når jeg setter i hodetelefoner slår ikke lenger lyden seg av på høyttalerne, så jeg får lyd i både høyttalerne og i hodetelefonene, og det er j** irriterende i disse eksamenslesingstider – får ikke hørt på musikk på lesesal i det hele tatt på grunn av det. Skal visst gå an å fikse i alsamixer, men der «finnes» ikke hodetelefonene i det hele tatt. Sykt irriterende.
    Men ellers er alt greit, ikke noe annet å klage på.

  14. Eirik says:

    @Jon: Ubuntus håndtering av lyd de siste par versjonene har vært alt annet enn perfekt, for å si det mildt. Selv måtte jeg mekke mye med Skype for å løse Pulseaudio-problemer under Jaunty, har ennå ikke startet det opp i Karmic for å teste om lyden funker, men frykter det verste…

  15. Svært interessant, eg er for godt planta i den lettare rosa Mac-verda til å tore å ta spranget heilt ut i Linux-land enno, sjølv om noe i meg seier at det er det rette å gjere. Denne moralske undertonen eg sjølv kjenner på, og har sansen for, i desse os-spørsmåla (bekjemp overvåkings- og innlukkingsregima med å støtte dei opne initiativa og standardane) gjer meg derfor svak for kommentarar som Atle her kjem med. Atle: du er jo Job! Alle pinslene dei binære gudane måtte kaste på deg, får deg ikkje til å vike frå trua di, tvert om, det gjer deg fastare :-)

  16. Lydproblemer ja – det glemte jeg å nevne. Jeg har nemlig det lille problemet at ikke lyden mutes når jeg kobler til headset eller ekstrerne høyttalere. Det fikser jeg imidlertid med å oppgradere ALSA ved hjelp av scriptet på denne siden: http://ubuntuforums.org/showthread.php?t=962695

  17. Kjell Inge Iversen says:

    Netcom mobilt bredbånd med ZTE MF636 adapter virker ikke.
    Dette virket i Ubuntu 9.04.
    Har nå gått tilbake til 9.04 inntil videre.

  18. Eirik says:

    @Kjell: Kjipt. Mitt Netcom Huawei-adapter fungerer helt OK under Karmic, heldigvis.

  19. Martin says:

    Er noen gang noe med slagordet: “If it ain’t broken, don’t fix it!”

  20. Kim says:

    Jeg har samme nettbok som deg Eirik, og har ikke de problemene du har. Alt har funket ut av boksen, vell alt utenom trådløs som var ustabil (oppdaterte kernel til 2.6.32-rc6 for å fikse dette). Jeg installerte 9.10 fra grunnen av. Bruker pidgin av gammel vane, men har testet empathy og har ikke hatt problemer der. Evolution funker fint, det samme gjør vlc. Dvale funker også bra, men jeg bruker den ikke ofte så jeg kan ikke si om den er ustabil…
    Bruker ikke ekstern skjerm så jeg har ikke fått testet det.
    Bruker eee-control på karmic, virker bra nok men venter på en offisiell versjon.

    Får opp noe om mount fs feil ved bootup av Karmic, har ikke giddet å sjekke dette opp ennå.

  21. Eirik says:

    @Kim: Takk for tilbakemeldingen. Er det denne uoffisielle eee-control-pakka du har brukt? http://danamlund.dk/eee-control/eee-control.html

  22. Kim says:

    Yepp, det er den jeg bruker.

  23. Eirik Newth says:

    @Kim: Jeg gjorde som deg, og installasjonen gikk helt greit. Akkurat nå ser det ikke ut til at jeg får like god levetid som under 9.04 eller XP, men det er en klar forbedring åkke som. Takker! :-)

  24. Kim says:

    Glad jeg kunne hjelpe :)
    Jeg får 7,5 time med lett bruk (internett), og får litt over 5 timer ved konstant videoavspilling. Kunne nok fått litt lengre tid hvis jeg brukte en annen nettleser, som Epiphany, men jeg er for glad i Opera. :D

  25. Eirik says:

    @Kim: Sikker på at vi har nøyaktig samme Eee? Min er spesifisert til å gi 4,5-5 timer med XP, og uten nettoppkobling gjør den det. Med Karmic får jeg rundt 4 timer. Med 3G, som tydeligvis suger mye strøm, får jeg 3 timer uansett OS.

  26. Kim says:

    Aha. Ser fra tidligere poster at du har 1000, jeg har 1000he.
    Kanskje denne er noe for deg siden du farter mye rundt? http://www.dealextreme.com/details.dx/sku.17082
    Klumpete, men billig.

  27. Eirik says:

    @Kim: Du kan tenke deg hvor irritert jeg var over å måtte kjøpe Eee 1000h like før det kom en modell med mye bedre spekker. Men slik er det nå engang for oss IT-kunder. Og det er greit å vite at man kan få 7,5 timer med Ubuntu OG nett. :-)

  28. Kim says:

    Hehe, kjenner til det ja :) Alltid noe bedre som kommer. Var ganske nær å kjøpe 1000, men leste en plass om 1000he og klarte såvidt å vente på den. Angrer ikke på det :) 7,5 timer med trådløs surfing, hvor jeg har huket av blåtann, eksternt skrivebord, sjekk for nye enhetsdrivere, Ubuntu One og visuell hjelpeteknologi(i oppstartsprogrammer). Og selfølgelig kjørt Powertop. Hadde 7,5 timer i XP, og har litt under 7 timer i en betaversjon av Windows 7.

  29. Kjell Inge Iversen says:

    Har installert karmic igjen.
    Fulgte denne oppskriften og nå fungerer MF636 modemet fra Netcom igjen.

    http://www.matt-barrett.com/2008/11/telstra-pre-paid-wireless-broadband-ubuntu/

  30. Skal dvale fungere så må swap være større enn fysisk minne.

  31. Eirik says:

    @John: Har sjekket det, og swap er større.

  32. Geir Grateng says:

    Har du vurdert å oppgradere til 10.04?

  33. Eirik says:

    @Geir: Det gjorde jeg forleden uke, faktisk. Kjøpte ny disk til Thinkpaden og installerte clean uten Windows. Så langt funker det helt nydelig. Kanskje jeg burde blogge? :-)

  34. Geir Grateng says:

    @Eirik: Blogg gjerne! Vil sette stor pris på flere detaljer.

Legg inn kommentar

Vis folkeskikk, vær relevant. Din ytringsfrihet er ikke min publikasjonsplikt.